ConnectorElementCreateConduitConnector(Document, Reference, Edge) Method |
Create a new conduit ConnectorElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ConnectorElement CreateConduitConnector(
Document document,
Reference planarFace,
Edge edge
)
Public Shared Function CreateConduitConnector (
document As Document,
planarFace As Reference,
edge As Edge
) As ConnectorElement
public:
static ConnectorElement^ CreateConduitConnector(
Document^ document,
Reference^ planarFace,
Edge^ edge
)
static member CreateConduitConnector :
document : Document *
planarFace : Reference *
edge : Edge -> ConnectorElement
Parameters
- document Document
-
The document to add the connector to.
- planarFace Reference
-
The planar face to place the connector on.
- edge Edge
-
One of the edges in the edge loop that defines the connector location on the planar face.
Return Value
ConnectorElement
The conduit ConnectorElement.
Exceptions
Remarks
Regenerates the document.
See Also