FamilyManagerSetDescription Method |
Set the description for an existing family parameter.
The description will be used as tooltip in the Revit UI including in the properties palette.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetDescription(
FamilyParameter familyParameter,
string description
)
Public Sub SetDescription (
familyParameter As FamilyParameter,
description As String
)
public:
void SetDescription(
FamilyParameter^ familyParameter,
String^ description
)
member SetDescription :
familyParameter : FamilyParameter *
description : string -> unit
Parameters
- familyParameter FamilyParameter
- The family parameter.
- description String
- The description of the family parameter.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the input argument-"familyParameter"-is .
|
ArgumentException |
Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
|
See Also