FabricationDimensionDefinition Class

Represents the definition of a single fabrication pattern dimension. Together all dimensions represent the parametric definition of the fabrication part.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFabricationDimensionDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationDimensionDefinition : IDisposable

The FabricationDimensionDefinition type exposes the following members.

Properties
 NameDescription
Public propertyIsModifiable If the fabrication dimension is modifiable by user.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName Fabrication dimension name.
Public propertyType Fabrication dimension type.
Public propertyUnitType Fabrication dimension unit type.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FabricationDimensionDefinition
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also