DirectShapeReferenceOptionsSetExternalGeometryId Method |
Sets the ExternalGeometryId associated with the reference object.
The ID must be non-empty.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DirectShapeReferenceOptions SetExternalGeometryId(
ExternalGeometryId externalId
)
Public Function SetExternalGeometryId (
externalId As ExternalGeometryId
) As DirectShapeReferenceOptions
public:
DirectShapeReferenceOptions^ SetExternalGeometryId(
ExternalGeometryId^ externalId
)
member SetExternalGeometryId :
externalId : ExternalGeometryId -> DirectShapeReferenceOptions
Parameters
- externalId ExternalGeometryId
-
Return Value
DirectShapeReferenceOptions
Exceptions
See Also