IFCCategoryTemplateGetCategoryMappingTable Method |
Gets the table that contains a mapping from Revit categories to IFC entities.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo> GetCategoryMappingTable(
Document document
)
Public Function GetCategoryMappingTable (
document As Document
) As IDictionary(Of ExportIFCCategoryKey, ExportIFCCategoryInfo)
public:
IDictionary<ExportIFCCategoryKey^, ExportIFCCategoryInfo^>^ GetCategoryMappingTable(
Document^ document
)
member GetCategoryMappingTable :
document : Document -> IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo>
Parameters
- document Document
-
The document.
Return Value
IDictionaryExportIFCCategoryKey,
ExportIFCCategoryInfo
The mapping table.
Exceptions
See Also