CompoundStructureStructuralMaterialIndex Property |
Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int StructuralMaterialIndex { get; set; }
Public Property StructuralMaterialIndex As Integer
Get
Set
public:
property int StructuralMaterialIndex {
int get ();
void set (int value);
}
member StructuralMaterialIndex : int with get, set
Property Value
Int32
The index of the layer containing the structural material properties.
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The specified layer cannot define the structural material properties of the type.
|
ArgumentOutOfRangeException |
When setting this property: The layer index is invalid.
|
See Also