The view used for geometry extraction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic View View { get; set; }
Public Property View As View
Get
Set
public:
property View^ View {
View^ get ();
void set (View^ value);
}
member View : View with get, set
Property Value
View
ExceptionsException | Condition |
---|
ArgumentNullException | Thrown when setting this property with a . |
InvalidOperationException | Thrown when setting this property,
if DetailLevel is already set. When DetailLevel is set view-specific geometry can't be
extracted. |
RemarksIf a view-specific version of an element exists, it will be extracted in the
retrieval of geometry. Also, the detail level of the geometry will be taken from the
view's detail level.
See Also