EdgeGetCurveUV(Int32, Transform2D) Method |
Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces.
The output curve's direction will follow the parametric direction of the edge, not the topological
direction of the edge on the given face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CurveUV GetCurveUV(
int index,
Transform2D transform
)
Public Function GetCurveUV (
index As Integer,
transform As Transform2D
) As CurveUV
public:
CurveUV^ GetCurveUV(
int index,
Transform2D^ transform
)
member GetCurveUV :
index : int *
transform : Transform2D -> CurveUV
Parameters
- index Int32
- The index of the face (0 or 1).
- transform Transform2D
- Transformation to apply to the curve.
Return Value
CurveUVIf successful, returns the calculated and transformed CurveUV,
otherwise.
Exceptions
RemarksUse of this function is preferred over using GetCurveUV(int index) and then transforming the curve, as the latter approach may yield a less accurate result.
See Also