LogicalAndFilter(IListElementFilter) Constructor

Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public LogicalAndFilter(
	IList<ElementFilter> filters
)

Parameters

filters  IListElementFilter
A collection of input filters.
Exceptions
ExceptionCondition
ArgumentException The filter collection is empty, or contains invalid inputs.
ArgumentNullException A non-optional argument was null
Remarks
The input filters will be copied.
See Also