FamilyManagerSetFormula Method |
Set the formula of a family parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetFormula(
FamilyParameter familyParameter,
string formula
)
Public Sub SetFormula (
familyParameter As FamilyParameter,
formula As String
)
public:
void SetFormula(
FamilyParameter^ familyParameter,
String^ formula
)
member SetFormula :
familyParameter : FamilyParameter *
formula : string -> unit
Parameters
- familyParameter FamilyParameter
- The family parameter.
- formula String
- The formula string, input to clean the formula of the parameter.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the input argument-"familyParameter"-is .
|
InvalidOperationException |
Thrown when there is no valid family type,
or the parameter cannot be assigned a formula,
or the operation make a circular chain of references among the formulas.
|
See Also