HVACLoadSpaceTypeSpaceTypeName Property |
The space type name.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string SpaceTypeName { get; set; }
Public Property SpaceTypeName As String
Get
Set
public:
property String^ SpaceTypeName {
String^ get ();
void set (String^ value);
}
member SpaceTypeName : string with get, set
Property Value
String
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: name is an empty string or contains only whitespace.
-or-
When setting this property: name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
When setting this property: The given value for name is already in use as a space type name.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also