BooleanOperationsUtilsCutWithHalfSpace Method |
Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Solid CutWithHalfSpace(
Solid solid,
Plane plane
)
Public Shared Function CutWithHalfSpace (
solid As Solid,
plane As Plane
) As Solid
public:
static Solid^ CutWithHalfSpace(
Solid^ solid,
Plane^ plane
)
static member CutWithHalfSpace :
solid : Solid *
plane : Plane -> Solid
Parameters
- solid Solid
-
The input Solid to be cut.
- plane Plane
-
The cut plane. The space on the positive side of the normal of the plane will be intersected with the input Solid.
Return Value
Solid
The newly created Solid.
Exceptions
See Also