ConnectorCoordinateSystem Property

The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual Transform CoordinateSystem { get; }

Property Value

Transform

Implements

IConnectorCoordinateSystem
Exceptions
ExceptionCondition
InvalidOperationException Thrown when the connector is of logical type.
InvalidOperationException Thrown on failure to get coordinate system.
Remarks
The coordinate system's origin is the location of the connector and the Z-axis is normal to the connector.
See Also