ViewDisplayStyle Property |
The DisplayStyle of the view.
Returns DisplayStyle.Wireframe if the view has no display style.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DisplayStyle DisplayStyle { get; set; }
Public Property DisplayStyle As DisplayStyle
Get
Set
public:
property DisplayStyle DisplayStyle {
DisplayStyle get ();
void set (DisplayStyle value);
}
member DisplayStyle : DisplayStyle with get, set
Property Value
DisplayStyle
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: DisplayStyle cannot be set to Undefined.
-or-
When setting this property: DisplayStyle of Drafting Views can be set only to Wireframe or HLR
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
When setting this property: DisplayStyle cannot be modified.
-or-
When setting this property: This view does not contain display-related properties.
|
See Also