CurveLoopIsCounterclockwise Method |
Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with
respect to the specified 3D direction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsCounterclockwise(
XYZ normal
)
Public Function IsCounterclockwise (
normal As XYZ
) As Boolean
public:
bool IsCounterclockwise(
XYZ^ normal
)
member IsCounterclockwise :
normal : XYZ -> bool
Parameters
- normal XYZ
-
The normal vector to the plane used for this determination.
Return Value
Boolean
True if the curve loop is oriented counter-clockwise with respect to the specified 3D direction,
false if the loop is oriented clockwise.
Exceptions
Remarks
CCW means that the projection of the CurveLoop onto a plane having "normal" as its oriented normal is CCW.
This method should only be called if the loop is closed and has a non-singular projection onto the plane
(i.e., the projection should have no self-intersections and should not be degenerate or even
nearly degenerate). The return value in other cases is indeterminate.
See Also