BuiltInFailuresMassFailures Class

Failures about Mass.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresMassFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class MassFailures

The BuiltInFailuresMassFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAutoGlazingFailed Failure in Auto-Glazing region computation.
Public propertyStatic memberAutoGlazingFailedError Failure in Auto-Glazing region computation.
Public propertyStatic memberBooleanUnionFailed Failed to merge overlapping solids
Public propertyStatic memberCannotIntegrate In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.
Public propertyStatic memberCannotMergeGeometry The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won't be computed.
Public propertyStatic memberCannotMoveMassing Can't move whole Massing. Move the elements within the Massing instead.
Public propertyStatic memberCreateCoreGeometryFailed Failed to create core geometries.
Public propertyStatic memberDividePerimeterZoneFailed Failed to divide perimeter zone.
Public propertyStatic memberFaceRegionCreationFailed Failure in face region creation.
Public propertyStatic memberFaceSplitFailed A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.
Public propertyStatic memberFloorAreaFaceFailed Failed to create a Mass Floor.
Public propertyStatic memberFloorMightLookWrong Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.
Public propertyStatic memberFloorRecreateFailed The floor cannot be created.
Public propertyStatic memberFloorRecreateFailedWarning The floor cannot be created because no suitable level in the target document can be found.
Public propertyStatic memberMinSkylightWidthImperial The minimum skylight width is 8 inches.
Public propertyStatic memberMinSkylightWidthMetric The minimum skylight width is 203.2 millimeters.
Public propertyStatic memberMultipleMassing Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.
Public propertyStatic memberNoCurtainRoofsInMassing Massing cannot be created with a curtain roof. Please change the default roof type and try again.
Public propertyStatic memberNonOccupiableMassZone For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.
Public propertyStatic memberNoSolidInMass Mass contains no solid geometry. Mass Floors, volume, and surface area, won't be computed.
Public propertyStatic memberOpenAndSolidGeometry Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.
Public propertyStatic memberOpenGeometryOnly Mass contains only mesh geometry, which can't be used to compute Mass Floors, volume, or surface area.
Public propertyStatic memberOverlappingSolids Found volumetric overlap between solids. They will be merged into one
Public propertyStatic memberSketchCurveNotModelable This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.
Public propertyStatic memberSplitFacesByGroundPlaneCrashed Failed to split face by ground plane.
Public propertyStatic memberSplitFacesByGroundPlaneFailed Failed to split face by ground plane.
Public propertyStatic memberSplitOverlappingFacesFailed Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.
Public propertyStatic memberTooManyGeometries The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.
Public propertyStatic memberUpgradedMassingWarning Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.
Top
See Also