MEPNetworkIterator(Document, MEPAnalyticalModelData, ConnectorDomainType) Constructor |
Creates an iterator by the analytical model data to visit all connected components in the network.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic MEPNetworkIterator(
Document pADoc,
MEPAnalyticalModelData seed,
ConnectorDomainType eDomain
)
Public Sub New (
pADoc As Document,
seed As MEPAnalyticalModelData,
eDomain As ConnectorDomainType
)
public:
MEPNetworkIterator(
Document^ pADoc,
MEPAnalyticalModelData^ seed,
ConnectorDomainType eDomain
)
new :
pADoc : Document *
seed : MEPAnalyticalModelData *
eDomain : ConnectorDomainType -> MEPNetworkIterator
Parameters
- pADoc Document
-
The document of the analytical network.
- seed MEPAnalyticalModelData
-
The analytical model data of the starting element.
- eDomain ConnectorDomainType
-
The domain of network that the iteration happens.
Exceptions
See Also