BRepBuilderPersistentIdsAddSubTag Method |
Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId.
Note that an existing correspondence in the map cannot be updated and that a
particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddSubTag(
ExternalGeometryId externalGeometryId,
BRepBuilderGeometryId brepBuilderGeometryId
)
Public Sub AddSubTag (
externalGeometryId As ExternalGeometryId,
brepBuilderGeometryId As BRepBuilderGeometryId
)
public:
void AddSubTag(
ExternalGeometryId^ externalGeometryId,
BRepBuilderGeometryId^ brepBuilderGeometryId
)
member AddSubTag :
externalGeometryId : ExternalGeometryId *
brepBuilderGeometryId : BRepBuilderGeometryId -> unit
Parameters
- externalGeometryId ExternalGeometryId
-
An external geometry object Id.
- brepBuilderGeometryId BRepBuilderGeometryId
-
A BRepBuilder geometry object Id. It must represent the ID of either a Face or an Edge.
ExceptionsException | Condition |
---|
ArgumentException |
externalGeometryId cannot be used to create a new correspondence because it is already used.
-or-
brepBuilderGeometryId cannot be used to create a new correspondence because it is already used.
-or-
brepBuilderGeometryId cannot be used to create a new correspondence because it doesn't represent the ID of either a Face or an Edge.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The associated BRepBuilder doesn't exist or is not valid (has no Faces and no Edges).
|
See Also