IFCCategoryTemplateImportFromFile Method |
Import mapping template from a text file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IFCCategoryTemplate ImportFromFile(
Document document,
string fileName,
string templateName
)
Public Shared Function ImportFromFile (
document As Document,
fileName As String,
templateName As String
) As IFCCategoryTemplate
public:
static IFCCategoryTemplate^ ImportFromFile(
Document^ document,
String^ fileName,
String^ templateName
)
static member ImportFromFile :
document : Document *
fileName : string *
templateName : string -> IFCCategoryTemplate
Parameters
- document Document
-
A Revit document.
- fileName String
-
A full text file name.
- templateName String
-
A mapping template name.
Return Value
IFCCategoryTemplate
The mapping template element.
Exceptions
See Also