ProjectPosition(Double, Double, Double, Double) Constructor |
Construct a new ProjectPosition with the specified
East/West offset, North/South offset, elevation offset,
and angle of rotation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ProjectPosition(
double ew,
double ns,
double elevation,
double angle
)
Public Sub New (
ew As Double,
ns As Double,
elevation As Double,
angle As Double
)
public:
ProjectPosition(
double ew,
double ns,
double elevation,
double angle
)
new :
ew : float *
ns : float *
elevation : float *
angle : float -> ProjectPosition
Parameters
- ew Double
-
East/West offset
- ns Double
-
North/South offset
- elevation Double
-
Elevation offset
- angle Double
-
Rotation from true north, in radians
Remarks
The angle parameter must be in the range of -PI to PI.
If the parameter value is outside that range, it
will be shifted by 2*PI until it falls into range.
See Also