OpenForeignOption Enumeration |
Options for opening files saved by an application that was not developed or licensed by Autodesk.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum OpenForeignOption
Public Enumeration OpenForeignOption
public enum class OpenForeignOption
MembersMember name | Value | Description |
---|
Open | 0 |
Do not show any prompt to the user if a foreign file is detected. Proceed to open.
|
DoNotOpen | 1 |
Do not show any prompt to the user if a foreign file is detected. Cancel this operation (do not open the file).
|
Prompt | 2 |
If possible, show a prompt to the user if a foreign file is detected. The operation may proceed or cancel based on the response.
|
See Also