LinkLoadResultGetExternalResourceReferencesFromFailedLoads Method |
Searches this and all nested LinkLoadResults, and returns a list
of ExternalResourceReferences for the links that failed to load.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ExternalResourceReference> GetExternalResourceReferencesFromFailedLoads()
Public Function GetExternalResourceReferencesFromFailedLoads As IList(Of ExternalResourceReference)
public:
IList<ExternalResourceReference^>^ GetExternalResourceReferencesFromFailedLoads()
member GetExternalResourceReferencesFromFailedLoads : unit -> IList<ExternalResourceReference>
Return Value
IListExternalResourceReference
A collection of link ExternalResourceReferences which failed to load.
Remarks In cases, where a nested structure of several links were loaded, this
method is intended to be a convenient way for IExternalResourceUIServers to
determine whether a top-level link, or any sub-link, which failed to load
properly was provided by their IExternalResourceServer or another server.
If this link and all nested links loaded successfully, then an empty list is returned.
See Also