TextElementCoord Property |
Position of the text (in model coordinates.)
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ Coord { get; set; }
Public Property Coord As XYZ
Get
Set
public:
property XYZ^ Coord {
XYZ^ get ();
void set (XYZ^ value);
}
member Coord : XYZ with get, set
Property Value
XYZ
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: A valid point must not be father then 10 miles (approx. 16 km) from the origin.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
RemarksThe position defines a point on the edge of the text area,
not a point on the border (if a border is defined for the style.)
It means that if the width of the border gets changed, the
position of the text area remains unchanged.
The relation of the position point with respect
to the text area depends on the text alignment as follows:
- For Left-aligned text the point is at the Left-Top corned of the box.
- For Center-aligned text the point is at the Middle-Top corned of the box.
- For Right-aligned text the point is at the Right-Top corned of the box.
See Also