UpdaterRegistrySetIsUpdaterOptional Method |
Sets a flag indicating whether an updater is optional or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SetIsUpdaterOptional(
UpdaterId id,
bool isOptional
)
Public Shared Sub SetIsUpdaterOptional (
id As UpdaterId,
isOptional As Boolean
)
public:
static void SetIsUpdaterOptional(
UpdaterId^ id,
bool isOptional
)
static member SetIsUpdaterOptional :
id : UpdaterId *
isOptional : bool -> unit
Parameters
- id UpdaterId
-
Id of the updater
- isOptional Boolean
-
Use True to make the updater optional, false to make it a mandatory updater.
Exceptions
Remarks
This flag controls whether an updater is going to be required next time a document in which
it had been used is opened. If a non-optional updater is not found (currently not registered)
in a document, the end user will be presented with a warning and choices to resolve
the situation.
See Also