EdgeGetEndPointReference Method

Returns a stable reference to the start or the end point of the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Reference GetEndPointReference(
	int index
)

Parameters

index  Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference
Reference to the point or if reference cannot be obtained.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException Thrown when the specified index is not 0 or 1.
InvalidOperationException Thrown when the object is internally marked as read-only in the setter.
See Also