BoundingBoxIsInsideFilterTolerance Property |
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double Tolerance { get; set; }
Public Property Tolerance As Double
Get
Set
public:
property double Tolerance {
double get ();
void set (double value);
}
member Tolerance : float with get, set
Property Value
Double
Remarks
By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic.
If the tolerance is positive, the iterated element's Outline may extend the tolerance distance outside of the given Outline in each coordinate to be a match.
If the tolerance is negative, the iterated element's Outline must lie at least the tolerance distance inside the given Outline in each coordinate to be a match.
See Also