FabricationItemFolder Class

A fabrication item folder that can contain sub folders and access to the FabricationItemFiles contained within.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFabricationItemFolder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationItemFolder : IDisposable

The FabricationItemFolder type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The item folder's name.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FabricationItemFolder
Public methodGetItemFiles Gets the item files in this item folder.
Public methodGetSubFolders Gets the item folder's sub folders.
Top
See Also