RevisionCreate Method

Creates a new Revision in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Revision Create(
	Document document
)

Parameters

document  Document
The document of the new Revision.

Return Value

Revision
The newly created Revision.
Exceptions
ExceptionCondition
ArgumentException document is not a project document.
ArgumentNullException A non-optional argument was null
Remarks
The new Revision will be added at the end of the sequence of existing Revisions.
Example
private Revision AddNewRevision(Document document, string description, string issuedBy, string issuedTo, ElementId sequenceNumber, DateTime date)
{
    Revision newRevision = Revision.Create(document);
    newRevision.Description = description;
    newRevision.IssuedBy = issuedBy;
    newRevision.IssuedTo = issuedTo;
    newRevision.RevisionNumberingSequenceId = sequenceNumber;
    newRevision.RevisionDate = date.ToShortDateString();
    return newRevision;
}
See Also