RebarShapeDrivenAccessorHeight Property |
For a spiral, the overall height.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double Height { get; set; }
Public Property Height As Double
Get
Set
public:
property double Height {
double get ();
void set (double value);
}
member Height : float with get, set
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: height must be positive.
|
InvalidOperationException |
This RebarShapeDrivenAccessor is not an instance of a spiral shape.
-or-
This RebarShapeDrivenAccessor doesn't contain a valid rebar reference.
|
Remarks
Applies only to instances where RebarShape.Definition is of type
RebarShapeDefinitionByArc, and its Type property is equal to the value
RebarShapeDefinitionByArcType.Spiral.
See Also