An enumerated type listing special types that can appear in an
ExportLayerTable.
These types do not represent an independent category in Revit, but can be mapped to specific layers on export.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Enumeration SpecialType
public enum class SpecialType
MembersMember name | Value | Description |
---|
InteriorWall | 1 |
The special type representing interior walls.
|
ExteriorWall | 2 |
The special type representing exterior walls.
|
FoundationWall | 3 |
The special type representing foundation walls.
|
RetainingWall | 4 |
The special type representing retaining walls.
|
Default | -1 |
The default value for most Revit categories and subcategories.
|
See Also