IPointCloudEngine Interface

An interface that controls the behavior of the link from Revit to a custom Point Cloud Engine.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IPointCloudEngine

The IPointCloudEngine type exposes the following members.

Methods
 NameDescription
Public methodCreatePointCloudAccess Implement this method to construct the IPointCloudAccess interface for the point cloud designated by the identifier. This method is called once during the creation of a PointCloudType.
Public methodFree Revit will call this method when done using the engine.
Top
Remarks
An instance of this interface should be created by the engine provider and registered with the PointCloudEnginesRegistry. The engine may associated with a particular file name extension during registration (for example, Revit supplies a built-in engine for working with files with the extension "rcs" or "rcp"). Alternatively, the engine may be associated with an identifier which is not expected to the be the extension of a particular file.
See Also