VertexPositionNormal Constructor |
Constructs the vertex from a point and a normal vector.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic VertexPositionNormal(
XYZ position,
XYZ normal
)
Public Sub New (
position As XYZ,
normal As XYZ
)
public:
VertexPositionNormal(
XYZ^ position,
XYZ^ normal
)
new :
position : XYZ *
normal : XYZ -> VertexPositionNormal
Parameters
- position XYZ
-
The vertex's position.
- normal XYZ
-
The vertex's normal vector.
Exceptions
See Also