AnalyticalSupportPriority Enumeration |
Defines how "highly" another Element is giving support for one Element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum AnalyticalSupportPriority
Public Enumeration AnalyticalSupportPriority
public enum class AnalyticalSupportPriority
type AnalyticalSupportPriority
MembersMember name | Value | Description |
---|
UnknownPriority | 0 |
Priority has not been determined.
|
HighestPriority | 1 | |
SecondHighestPriority | 2 | |
ThirdHighestPriority | 3 | |
FourthHigestPriority | 4 | |
Remarks
For instance, a Column may be a higher priority for a Beam than another Beam.
This is useful to find the best supports for a given Element.
See Also