SpatialFieldManagerIsResultSchemaNameUnique Method

Verify the uniqueness of the name among all registered result schemas.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsResultSchemaNameUnique(
	string name,
	int resultIndexToSkip
)

Parameters

name  String
Name to verify uniqueness of.
resultIndexToSkip  Int32
Index of result (e.g. to be replaced) which names should not count for uniqueness; negative number means nothing is excluded from comparison.

Return Value

Boolean
True if name is unique, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also