RebarHostDataIsValidHost Method |
Reports whether the element is a valid rebar host.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidHost()
Public Function IsValidHost As Boolean
public:
bool IsValidHost()
member IsValidHost : unit -> bool
Return Value
Boolean
True if the referenced Element can currently host Rebar elements,
false otherwise.
Remarks
If GetRebarHostData() returns a RebarHostData object,
but RebarHostData.IsValidHost() returns false, this means
that the element can be made
a valid rebar host, generally by setting a property
like FLOOR_PARAM_IS_STRUCTURAL or by changing the
element's physical material to concrete. On the other
hand, if GetRebarHostData() returns , the element
cannot be made into a rebar host.
See Also