DocumentIsReadOnlyFile Property |
Signals whether the document was opened from a read-only file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsReadOnlyFile { get; }
Public ReadOnly Property IsReadOnlyFile As Boolean
Get
public:
property bool IsReadOnlyFile {
bool get ();
}
member IsReadOnlyFile : bool with get
Property Value
Boolean
Remarks
A document could be opened this way when, for example, at the time of opening
the file was being used by another Revit user, or if the disk file has the read-only attribute set.
Although it will still be possible to modify the opened document,
any changes made there will not be possible to save into the original file.
If the changes are to be preserved, the document must be saved under a different
name using the SaveAs() method.
See Also