RevitLinkTypeUpdateFromIFC(Document, String, String, Boolean) Method |
Updates a Revit link type from an IFC file and loads the linked document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool UpdateFromIFC(
Document document,
string ifcFilePath,
string revitLinkedFilePath,
bool recreateLink
)
Public Function UpdateFromIFC (
document As Document,
ifcFilePath As String,
revitLinkedFilePath As String,
recreateLink As Boolean
) As Boolean
public:
bool UpdateFromIFC(
Document^ document,
String^ ifcFilePath,
String^ revitLinkedFilePath,
bool recreateLink
)
member UpdateFromIFC :
document : Document *
ifcFilePath : string *
revitLinkedFilePath : string *
recreateLink : bool -> bool
Parameters
- document Document
-
The document that contains Revit link.
- ifcFilePath String
-
The path of the IFC link to load. This must be a full path.
- revitLinkedFilePath String
-
The path of the Revit file to create to hold the IFC information. This must be a full path.
- recreateLink Boolean
-
If true, the Revit file will be updated based on the information in the IFC file. If false, the existing Revit file will be used.
Return Value
Boolean
Returns true if the update succeeded, false otherwise.
Exceptions
Remarks
This function regenerates the input document.
While the options argument allows specification of a path type, the
input path argument must be a full path. Relative vs. absolute determines
how Revit will store the path, but it needs a complete path to find
the linked document initially.
Note that the IFC file will not be stored directly in the document; it will
instead by stored in an intermediate Revit document, whose location is given
by revitLinkedFilePath.
See Also