TextElementKeepRotatedTextReadable Property |
A flag to control how text behaves inside a rotated text element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool KeepRotatedTextReadable { get; set; }
Public Property KeepRotatedTextReadable As Boolean
Get
Set
public:
property bool KeepRotatedTextReadable {
bool get ();
void set (bool value);
}
member KeepRotatedTextReadable : bool with get, set
Property Value
Boolean
RemarksIf the property is True then the text inside the text box gets oriented
so it is readable when looking straight up at the sheet or from its right side;
in other words, the text would never be upside down.
If the value is False, however, the text's orientation strictly follows
the rotation of the text box, which means the text may be upside down when
viewed on screen or printed on a sheet.
See Also