FabricationServiceSetServicePaletteExclusions Method |
Sets the service palette exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those palettes passed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SetServicePaletteExclusions(
IList<int> excludedPalettes
)
Public Function SetServicePaletteExclusions (
excludedPalettes As IList(Of Integer)
) As Boolean
public:
bool SetServicePaletteExclusions(
IList<int>^ excludedPalettes
)
member SetServicePaletteExclusions :
excludedPalettes : IList<int> -> bool
Parameters
- excludedPalettes IListInt32
-
A list of service palette indexes to be excluded.
Return Value
Boolean
Returns true if succeeded to set the exclusions to the specified palette(s).
Exceptions
See Also