FillPatternElementGetFillPatternElementByName Method

Retrieves the FillPatternElement by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FillPatternElement GetFillPatternElementByName(
	Document document,
	FillPatternTarget target,
	string name
)

Parameters

document  Document
The document in which to retrieve the FillPatternElement.
target  FillPatternTarget
The FillPatternTarget of the FillPatternElement.
name  String
The name of the FillPatternElement.

Return Value

FillPatternElement
The FillPatternElement.
Exceptions
ExceptionCondition
ArgumentException target must be Model or Drafting.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also