RebarShapeMultiplanarDefinitionSetPresenceOfSegments Method |
Simultaneously set the presence of all 3D segments.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetPresenceOfSegments(
bool isDuplicateShapePresent,
bool isStartConnectorPresent,
bool isEndConnectorPresent
)
Public Sub SetPresenceOfSegments (
isDuplicateShapePresent As Boolean,
isStartConnectorPresent As Boolean,
isEndConnectorPresent As Boolean
)
public:
void SetPresenceOfSegments(
bool isDuplicateShapePresent,
bool isStartConnectorPresent,
bool isEndConnectorPresent
)
member SetPresenceOfSegments :
isDuplicateShapePresent : bool *
isStartConnectorPresent : bool *
isEndConnectorPresent : bool -> unit
Parameters
- isDuplicateShapePresent Boolean
-
- isStartConnectorPresent Boolean
-
- isEndConnectorPresent Boolean
-
ExceptionsException | Condition |
---|
ArgumentsInconsistentException |
The shape is disconnected or forms a complete loop:
If the duplicate shape is present, exactly one of the connectors must be present.
|
See Also