FailureHandlingOptionsSetClearAfterRollback Method |
Sets a flag indicating that Revit should clear all posted failures silently when the failing transaction is being rolled back intentionally. If
not set, the failures may still be displayed to the user during rollback.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FailureHandlingOptions SetClearAfterRollback(
bool bFlag
)
Public Function SetClearAfterRollback (
bFlag As Boolean
) As FailureHandlingOptions
public:
FailureHandlingOptions^ SetClearAfterRollback(
bool bFlag
)
member SetClearAfterRollback :
bFlag : bool -> FailureHandlingOptions
Parameters
- bFlag Boolean
-
True to clear posted failures silently if the transaction is being rolled back, false to keep these failures in place (they may be displayed to the user).
Return Value
FailureHandlingOptions
This FailureHandlingOptions object.
See Also