RebarShapeMultiplanarDefinition Constructor |
Create a RebarShapeMultiplanarDefinition for use in creating a RebarShape.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarShapeMultiplanarDefinition(
double outOfPlaneBendDiameter
)
Public Sub New (
outOfPlaneBendDiameter As Double
)
public:
RebarShapeMultiplanarDefinition(
double outOfPlaneBendDiameter
)
new :
outOfPlaneBendDiameter : float -> RebarShapeMultiplanarDefinition
Parameters
- outOfPlaneBendDiameter Double
-
Bend diameter to be used when the rebar bends out of its main plane.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
The given value for outOfPlaneBendDiameter must be greater than 0 and no more than 30000 feet.
|
See Also