BoundingBoxIntersectsFilter(Outline, Double, Boolean) Constructor |
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline,
with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxIntersectsFilter(
Outline outline,
double tolerance,
bool inverted
)
Public Sub New (
outline As Outline,
tolerance As Double,
inverted As Boolean
)
public:
BoundingBoxIntersectsFilter(
Outline^ outline,
double tolerance,
bool inverted
)
new :
outline : Outline *
tolerance : float *
inverted : bool -> BoundingBoxIntersectsFilter
Parameters
- outline Outline
-
The Outline used to find elements with a bounding box that intersect it.
- tolerance Double
-
The tolerance value to use instead of zero. See the tolerance property for details.
- inverted Boolean
-
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.
ExceptionsException | Condition |
---|
ArgumentException |
outline is an empty Outline.
-or-
The given value for tolerance is not finite
-or-
The given value for tolerance is not a number
|
ArgumentNullException |
A non-optional argument was null
|
See Also