PipeSettingsGetSpecificFittingAngles Method |
Gets the list of specific fitting angles.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<double> GetSpecificFittingAngles()
Public Function GetSpecificFittingAngles As IList(Of Double)
public:
IList<double>^ GetSpecificFittingAngles()
member GetSpecificFittingAngles : unit -> IList<float>
Return Value
IListDouble
Angles (in degrees).
Remarks
Revit will only use the angles specified during the pipe layout or modifying the pipe layout.
When laying out the pipes, if the angle between two pipes is close to the allowed angle,
the specific angle is used for that pipe fitting.
See Also