DrawContextGetClipPlanes Method |
Gets the clipping planes for the Revit view where rendering takes place.
Clipping planes control the 3D extent of a view and can be set using Section Box in Revit.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ClipPlane> GetClipPlanes()
Public Shared Function GetClipPlanes As IList(Of ClipPlane)
public:
static IList<ClipPlane^>^ GetClipPlanes()
static member GetClipPlanes : unit -> IList<ClipPlane>
Return Value
IListClipPlane
The array of clipping planes, which is empty if none are set.
ExceptionsException | Condition |
---|
InvalidOperationException |
This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
|
See Also