ShapeImporterConvert Method |
Converts the geometry stored in the external format into a collection of Revit geometry objects.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<GeometryObject> Convert(
Document document,
string filename
)
Public Function Convert (
document As Document,
filename As String
) As IList(Of GeometryObject)
public:
IList<GeometryObject^>^ Convert(
Document^ document,
String^ filename
)
member Convert :
document : Document *
filename : string -> IList<GeometryObject>
Parameters
- document Document
-
The Revit document where the resulting Revit geometry objects will be used. This document may need to be modified
to store dependent elements such as graphics styles and/or materials.
- filename String
-
The full path to the input file.
Return Value
IListGeometryObject
A collection of Revit geometry objects created from the incoming data.
Exceptions
See Also