TableSectionDataIsDataOutOfDate Method |
Indicates whether the data in this section is out of date.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsDataOutOfDate()
Public Function IsDataOutOfDate As Boolean
public:
bool IsDataOutOfDate()
member IsDataOutOfDate : unit -> bool
Return Value
Boolean
True if the data in this section is out of date, false otherwise.
Remarks
To improve performance, some TableViews may contain TableSections that are only updated on demand. For example,
the body section of a schedule is not updated when the ViewSchedule is closed. In this case, you need to call
RefreshData to avoid getting the stale data.
See Also