ElectricalSettingAddWireMaterialType Method |
Add a new type of wire material.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic WireMaterialType AddWireMaterialType(
string name,
WireMaterialType baseMaterial
)
Public Function AddWireMaterialType (
name As String,
baseMaterial As WireMaterialType
) As WireMaterialType
public:
WireMaterialType^ AddWireMaterialType(
String^ name,
WireMaterialType^ baseMaterial
)
member AddWireMaterialType :
name : string *
baseMaterial : WireMaterialType -> WireMaterialType
Parameters
- name String
- Name of new material type.
- baseMaterial WireMaterialType
- Specify an existing material type which New material will be constructed based on.
Return Value
WireMaterialTypeNew added wire material type object.
See Also