UnitFormatUtils Class

A utility class for formatting and parsing numbers with units.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBUnitFormatUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class UnitFormatUtils

The UnitFormatUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberFormat(Units, ForgeTypeId, Double, Boolean) Formats a number with units into a string.
Public methodStatic memberFormat(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) Formats a number with units into a string.
Public methodStatic memberTryParse(Units, ForgeTypeId, String, Double) Parses a formatted string into a number with units if possible.
Public methodStatic memberTryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double) Parses a formatted string into a number with units if possible.
Public methodStatic memberTryParse(Units, ForgeTypeId, String, Double, String) Parses a formatted string into a number with units if possible.
Public methodStatic memberTryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double, String) Parses a formatted string into a number with units if possible.
Top
See Also